It appears you have not yet Signed Up with our community. To Sign Up for free, please click here....



Birth Control Message Board
Post New Thread   Closed Thread
LinkBack Thread Tools
Old 07-28-2012, 09:23 PM   #1
Newbie
(female)
 
Join Date: Jul 2012
Location: Sacramento California
Posts: 1
Lovemee HB User
Confused

My period started on the 4th or what i thought was my period & stopped that same day. I had unprotected sex at least 4 times that night.. Then on the 15th what looked to be my period started again so i started my pills (Levora0.15/30) & again my period stopped.. It was only there for maybe an hour just like on the 4th.. Is this normal?!?

 
Closed Thread




Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Join Our Newsletter

Stay healthy through tips curated by our health experts.

Whoops,

There was a problem adding your email Try again

Thank You

Your email has been added








TOP THANKED CONTRIBUTORS



Kszan (36), KREgirl09 (6), Princesa (5), lorileamc (5), Seraph (3), Remod (3), Titchou (3), tUrRrRa (2), sue19 (2), frankieswife (2)

Site Wide Totals

teteri66 (1162), MSJayhawk (992), Apollo123 (890), Titchou (827), janewhite1 (823), Gabriel (757), ladybud (744), sammy64 (666), midwest1 (665), BlueSkies14 (610)



All times are GMT -7. The time now is 02:33 AM.



Site owned and operated by HealthBoards.comô
Terms of Use © 1998-2014 HealthBoards.comô All rights reserved.
Do not copy or redistribute in any form!