It appears you have not yet Signed Up with our community. To Sign Up for free, please click here....



Infertility Message Board
Post New Thread   Closed Thread
LinkBack Thread Tools
Old 10-12-2003, 11:46 AM   #1
Inactive
 
Join Date: Jul 2003
Location: Illinois, USA
Posts: 84
Sarafina HB User
Post Help! Infection from HSG?

Hi, I had an HSG on Wednesday. It went so well that I went shopping right afterwards. From Wednesday afternoon to Friday morning I had a lot of pelvic pain, pretty bad at times and never really got out of bed because whenever I did it would all hurt worse. Friday am I called doctor and his nurse scheduled me to come in to see doctor saturday am. By this time I am also experiencing a frequent urgency to urinate which always produces a lot of urine (so I'm not thinking bladder infection). So I go to my doctor, he examines me and says I probably don't have an infection caused by the HSG procedure, but maybe I have a bladder infection, so he has me pee in a cup, and I won't get the results until tomorrow afternoon at the earliest. He gave me a prescription for antibiotics, which I didn't have filled for the following reasons:
1. No proof of infection yet.
2. If I take the antibiotics they will probably give me a yeast infection for next month. This pain - which I am convinced is somehow related to the HSG- has now screwed up my chance of getting pregnant this month because I am in too much pain to have sex, and last month was all screwed up because the lousy fertility meds drove me out of my mind and was too emotional and fighting with husband because of stress.
3. I am working with an acupuncturist and taking herbal medication and am concerned the antibiotics would interact.

So, has anyone out there had an infection after an HSG, or pain that lasted days?

Now I have severe pain in my lower back, left side, which I am thinking is probably the kidney. So I guess I better go ahead and get the antibiotics now.

Would we all increase our chances of getting pregnant if we just gave up on doctors???? -Sara

 
Sponsors Lightbulb
   
Old 10-12-2003, 12:45 PM   #2
Bam Bam is offline
Junior Member
 
Join Date: Jul 2002
Posts: 34
Bam HB User
Post

I am so sorry you are in such pain. I had cramping and bloating for several days after my HSG. However I took antibiotics prior to the procedure. My GYN is an excellent doctor but can be quite conservative (even though he is very young and innovative!). He told me that infections from the dye are rare, but they do happen and he prefers to do whatever is necessary to keep his patients from getting an infection, so he always prescribes the antibiotics. I took them and didn't get a yeast infection. Good luck!!!

 
Old 10-12-2003, 06:57 PM   #3
Veteran
 
Join Date: Jan 2003
Location: Morgan City, La. USA
Posts: 335
mandy911 HB User
Post

Hi I had the HSG and also took Antibiotics prior to the procedure. I had severe cramping after the procedure for about 2 days. Mild after that for about 1 day. Spotted for 3 days. If you got an infection from the HSG or you are in pain and don't know if you have an infection are not. I would still take the meds just incase. The HSG procedure involves a tube going into your uterus and you take no chances with that. An infection can damage your tubes and among other things. I don't want to scare you but I would take the meds just to be safe. I hope you start to feeling better soon.

Mandy
__________________
~~~~~Jesus thought you would be a beautiful flower for his bouquet~~~~~
( In Loving Memory of My Mother )
5-12-03
Tubal reversal 11-04-02
HSG tubes are open
DH SA 40mil
DD is 12 years old
DS is 10 years old
TTC #3 since Nov. of 2002
early miscarriage on Oct.30, 2003 (4 weeks 5 days)
Started clomid first cycle on Dec 26 2003(50mg)
~~~~
Mandy

 
Old 10-12-2003, 07:19 PM   #4
Inactive
 
Join Date: Jul 2003
Location: Illinois, USA
Posts: 84
Sarafina HB User
Post

Thanks, both of you, for your responses. I did go and get the antbiotics this afternoon, which is 4 days after the procedure - I guess, because I am in so much pain now - I am freaking out a bit because I don't know exactly what is infected - everything hurts and I can't even walk upright. Forget even trying to get pregnant this month. If my doctor were here in front of me right now he wouldn't be safe. I am hoping this is just some kind of urinary tract infection and not something that will screw up what turned out to be my perfectly unblocked tubes. I am soooooooooo mad I can't even speak outloud because I know I will lose it.
I'm pretty afraid too because I know something is wrong, just not sure what it is. I will post when I have an answer. I was never even offered antibiotics prior to the procedure and I also had not self-educated on the fact that risk of infection existed. So a word from the wise to anyone who has this lousy procedure in their future: Take antibiotics beforehand! I never take meds myself usually, but believe me it will be worth it to avoid being in this situation. Thanks again - Sara

 
Closed Thread

Similar Threads
Thread Thread Starter Board Replies Last Post
Please help ilduce520 Lyme Disease 2 05-30-2010 02:53 AM
Please someone help me !!!!!!!! abby1972 Addison's Disease 8 05-10-2010 10:04 PM
Puffy eyes, unusual tiredness, fatigue... Please Help!? Peachezz General Health 19 05-10-2010 09:58 AM
Keppra Help Please! tcedwards Epilepsy 2 04-26-2010 08:42 AM
I want my hair White can anybody help me? Blakeich Beauty & Cosmetics 2 04-26-2010 06:14 AM




Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Sign Up Today!

Ask our community of thousands of members your health questions, and learn from others experiences. Join the conversation!

I want my free account

All times are GMT -7. The time now is 06:46 AM.



Site owned and operated by HealthBoards.comô
Terms of Use © 1998-2014 HealthBoards.comô All rights reserved.
Do not copy or redistribute in any form!