It appears you have not yet Signed Up with our community. To Sign Up for free, please click here....



Lupus Message Board
Post New Thread   Closed Thread
LinkBack Thread Tools
Old 11-27-2008, 03:07 AM   #1
Newbie
(female)
 
Join Date: Nov 2008
Location: Brisbane, QLD, Australia
Posts: 2
UnknownUCTD HB User
Blood complements

Hi all,

I don't know if anyone can help but I just cant seem to get a clear answer. My Rheumy has been treating me for SLE but can't confirm this. He has now changed it to UCTD with Fibromyalgia. I have been getting blood tests done every couple months over the last 10months. I have been on Methotrexate 25mg weekly and was on prednisone. I was doing well and my C3 C4 hit the normal limit range after several months as I was well below the lowest. Within a month of my last tests the results have jumped dramatically backwards and am well under again. I am currently at 870 for C3 (lowest is 1050) and 100 for C4 (lowest is 130) . Can anyone tell me why this has jumped so far within a month? I have been feeling very ill and in a lot of pain. I am still waiting on my ANA's to come back. I don't get to see my Rheumy until end of next month and my GP doesn't know much about it.

 
Old 12-08-2008, 12:10 PM   #2
Member
(female)
 
Join Date: Jul 2008
Location: birmingham,alabama
Posts: 78
pixie1985 HB User
Re: Blood compliments

Hello...I am certainly not the pro on this disease as I have only been recently diagnosed. My Rheumatoligist tells me that the complement levels rise and fall with inflammation. You did not mention if you are taking any type of medication such as Plaquenil or inflammatory meds such as Advil or Aleve. My ANA titer was in the 2400 range, Sed rate, CRP, C3, and C4 levels were elevated. He started me on Plaquenil and labs are starting to return to normal. Hope everything works out for you. Take Care. Pix

 
Sponsors Lightbulb
   
Old 12-08-2008, 11:56 PM   #3
Newbie
(female)
 
Join Date: Nov 2008
Location: Brisbane, QLD, Australia
Posts: 2
UnknownUCTD HB User
Re: Blood compliments

Hi Pixie1985,

Sorry to hear about your condition, I am only recent myself being less than a year since diagnosis.
I am on Plaquenil, Methotrexate and Prednisone. As well as other drugs to help with the side effects from all of these. My ANA's came back within normal limits and still just as confused.... Its also strange as a everything else is within normal range too. My Dr is not keen on labelling anything at the moment so they are just treating the symptoms.

 
Closed Thread

Similar Threads
Thread Thread Starter Board Replies Last Post
Abdominal Pain, Gall Bladder Polyp & Blood test results ooSTEVEoo Gallbladder 10 08-25-2010 02:26 PM
Lupus and blood pressure spikes when sleeping. Sunsetnan Lupus 121 07-26-2010 07:21 AM
Ketchup colored blood from the vagina? Mr Slippers Women's Health 0 04-19-2010 03:17 PM
Blood Tinged Mucas with Constipation classylady01 Bowel Disorders 1 04-19-2010 04:15 AM
Perplexed About My High Blood Pressure conanld High & Low Blood Pressure 5 10-26-2008 11:09 AM




Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Join Our Newsletter

Stay healthy through tips curated by our health experts.

Whoops,

There was a problem adding your email Try again

Thank You

Your email has been added








TOP THANKED CONTRIBUTORS



VeeJ (172), ladybud (43), AngelicBrat (16), luca689 (7), ksp (6), neveragain444 (6), luvinmusiq (5), brooklyngirl (4), Daisygrace (4), AgedFlowerChild (3)

Site Wide Totals

teteri66 (1180), MSJayhawk (1006), Apollo123 (906), Titchou (850), janewhite1 (823), Gabriel (759), ladybud (755), midwest1 (669), sammy64 (668), BlueSkies14 (607)



All times are GMT -7. The time now is 02:34 PM.



Site owned and operated by HealthBoards.comô
Terms of Use © 1998-2014 HealthBoards.comô All rights reserved.
Do not copy or redistribute in any form!