It appears you have not yet Signed Up with our community. To Sign Up for free, please click here....



Urology Message Board
Post New Thread   Closed Thread
LinkBack Thread Tools
Old 08-21-2008, 06:14 PM   #1
Registered User
(female)
 
Join Date: Aug 2008
Location: england
Posts: 0
ameica HB User
i have a uti took all my antibiotics but its not going whats wrong

i have had 5 uti in the past year most of them have at least a couple months between them then 3 weeks ago i got one it felt like a normal uti no different to the ones i had my doc give me strong antibiotics then it went competely 4 days later it came back really bad i couldnt believe it i went back to my doc she checked my pee and yeah there was yet another infection she gave me another course of tablets i have just finished buti still get a irration down below its driving me insane someone please help and tell me i wont have this irratation forever thanks

 
Old 08-28-2008, 11:38 PM   #2
Newbie
(female)
 
Join Date: Aug 2008
Location: Shawnee,KS USA
Posts: 2
joyfulone3 HB User
Re: i have a uti took all my antibiotics but its not going whats wrong

I am going through the same thing and have been for a few months. I truly sympathize with you. I am scheduling an appointment with a urologist. I have decided my family doctor is not able to successfully treat this...she seems to be stumped and I am suffering. You might consider finding a urologist too. Don't wait as long as I have...this all started November '07 when I trace it back through the various ailments I have had. I think it started after I had a serious of colds and flu then a sinus infection for which I was given antibiotics. Then I was plagued with a series of UTI's and I haven't been able to kick them. Good luck. I honestly know how you feel.

 
Sponsors Lightbulb
   
Old 09-03-2008, 08:34 AM   #3
Inactive
(female)
 
Join Date: Apr 2008
Location: USA
Posts: 284
Linda1652 HB UserLinda1652 HB UserLinda1652 HB UserLinda1652 HB UserLinda1652 HB UserLinda1652 HB User
Re: i have a uti took all my antibiotics but its not going whats wrong

This happened to me. I ended up getting a UTI from a catheter. It didn't go away, and I ended up back in the hospital with sepsis. It went into my kidney.

They found out I was an "incomplete voider". Even though I though I was done urinating, my bladder was still half full!! They think I reinfected myself.

Make sure you void completely. An ultrasound after urinating is what detected my problem.

 
Closed Thread

Similar Threads
Thread Thread Starter Board Replies Last Post
stroke victims know whats going on? YoungLife Stroke 7 06-05-2010 03:27 AM
Took SUBOXONE FOR 6 1/2 YEARS! Finally OFF!! platinumgrl5050 Addiction & Recovery 9 03-29-2009 01:37 PM
Undiagnosed Lyme & took a 5 day ZPAK wdiguy Brain Tumors 6 03-22-2009 09:22 AM
i would realy really appreciate it if someone took the time out to actually read this theycallmelisx3 Personality Disorder 4 03-01-2009 09:55 PM
whats going on? sunshinegal71 Relationship Health 4 07-18-2008 06:06 PM




Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Join Our Newsletter

Stay healthy through tips curated by our health experts.

Whoops,

There was a problem adding your email Try again

Thank You

Your email has been added








TOP THANKED CONTRIBUTORS



bhp02 (12), ladybud (9), Millard (8), Mojo88 (6), albedo1 (6), LENNYI (5), Bob652 (4), jasno999 (3), dreamer54 (3), Jinny Jean (3)

Site Wide Totals

teteri66 (1182), MSJayhawk (1015), Apollo123 (913), Titchou (862), janewhite1 (823), Gabriel (763), ladybud (760), midwest1 (671), sammy64 (668), BlueSkies14 (607)



All times are GMT -7. The time now is 06:25 AM.



Site owned and operated by HealthBoards.comô
Terms of Use © 1998-2014 HealthBoards.comô All rights reserved.
Do not copy or redistribute in any form!