It appears you have not yet Signed Up with our community. To Sign Up for free, please click here....



Urology Message Board
Post New Thread   Reply Reply
LinkBack Thread Tools
Old 08-23-2011, 05:14 PM   #1
Newbie
(female)
 
Join Date: Sep 2010
Location: Poconos, PA.
Posts: 7
aikomama HB User
Question UTI symptoms... no infection

Hello! About a week ago I went to the doctor because I felt like I was getting a UTI. I had pressure in my bladder and felt like I had to urinate all the time. He did a dip stick test and found some blood and white blood cells in my urine. He put me on Macrobid (100mg-twice a day for 10 days). It has been a solid week and I feel no relief. I went back today and they said that the culture showed it wasn't a bladder infection but they didn't know what it could be. I still have pressure in my bladder and the urge to urinate. When I do go I go normally. My legs have felt a bit weak and I have slight lower back pain. I've been a bit nauseous but I'm not sure if it could be from the meds or not. I'm starting to freak out a bit because I've never had anything like this. Should I see a urologist or OBGYN? What could this be? Any information would be appreciated.

THanks so much!!

 
Reply With Quote
Old 08-25-2011, 11:15 AM   #2
Senior Member
(female)
 
Join Date: Jun 2008
Location: Green Brook, NJ usa
Posts: 231
Twinkie50 HB UserTwinkie50 HB UserTwinkie50 HB User
Re: UTI symptoms....no infection

Hi - I am in the same place right now. I am 52 and have never in my life had a UTI. I started peeing bubbles a few days ago ?? weird, I know...and my pee has had a odd odor off and on for a month or two. I drink tons of water and sometimes mid-day my urine would be pretty yellow and sometimes cloudy. I looked up peeing bubbles and it said it could be from protein spilling into the urine. I went to the doctor on Tuesday - they did a dip stick and everything was normal but trace blood. Put me on the same medication as you - same day I started having burning sensations and my legs feel weak too. My culture came back today normal ??????? So I am now concerned as to why I have blood and no infection??? I am going today for my complete physical which I have had scheduled with him for a few months now. My sister has blood in her urine all the time - has had CT scans of kidneys, bladder, etc. and they never find anything. I have concerns now too ....

 
Reply With Quote
The following user gives a hug of support to Twinkie50:
aikomama (08-26-2011)
Sponsors Lightbulb
   
Old 08-26-2011, 02:14 PM   #3
Junior Member
(female)
 
Join Date: Jun 2006
Location: Texas
Posts: 30
jocotter HB User
Re: UTI symptoms....no infection

If you guys keep having symptoms with no infections, then look up interstitial cystitis and read about that. I have that and it feels like a UTI, but isn't. Instead your bladder is inflamed. It's very frustrating and I hope you don't have it. Sometimes doctors don't know about it.

 
Reply With Quote
Old 08-26-2011, 05:22 PM   #4
Newbie
(female)
 
Join Date: Sep 2010
Location: Poconos, PA.
Posts: 7
aikomama HB User
Re: UTI symptoms....no infection

It's been 2 weeks now and I've finished all of the medicine but still feel no releif. I have an appt scheduled on Tues with my gyno to see if he can find anything. I'm starting to worry a bit because I have no idea what this is. It came on quite suddenly and I don't have a past history of UTI's so I'm starting to get a little scared and confused. Did you find anything out at your appt? I'll keep you informed as I hear anything. Wishing you well and hope we're feeling better soon!!

 
Reply With Quote
Old 08-26-2011, 05:25 PM   #5
Newbie
(female)
 
Join Date: Sep 2010
Location: Poconos, PA.
Posts: 7
aikomama HB User
Re: UTI symptoms....no infection

Can the cystitis come on out of no where? I've done a bit of research but it's all medical jargon and not real life people's accounts. It sounds like it would be terrible as I see there is no cure. So it's like a lifetime with UTI symptoms? I'm so sorry that you have to go through that. I'm keeping my fingers crossed that it's something treatable and nothing scary!

 
Reply With Quote
Old 07-16-2012, 11:01 AM   #6
Newbie
(female)
 
Join Date: Jul 2012
Location: Fort Worth, TX
Posts: 1
Ddouglas86 HB User
Unhappy Re: UTI symptoms....no infection

I've also experienced the same problems. Im 25 and two years ago I got my first UTI. Two months ago I had another UTI and was prescribed to Macrobid. After I finished the meds, I still had flare ups in my bladder but no infection. Now on Saturday I had really bad pains in my abdomen and I went to urgent care to get a urine culture done and it came back today...normal with no infection of a UTI and I'm furious because I don't know what's wrong with me. This pain has been keeping me out of work. I have an appointment with the OBGYN tomorrow and I hope he'll give me some positive news. But I read online that it could be interstitial cystitis (sp?), chlamydia, or ovarian cancer. I don't understand how it could be chlamydia because I'm not sexually active. I haven't had sex since April 2011. Have any of you figured out what the problem may be? Also, this Macrobid I'm prescribed to again is giving me different symptoms of diarrhea and drowsiness which I didnt experience the first time around...yet the assistant at urgent care said I should keep taking the meds even though I don't have an infection....? I'm confused by that.

 
Reply With Quote
Old 07-16-2012, 11:27 PM   #7
Newbie
(female)
 
Join Date: Jul 2012
Location: California
Posts: 2
MaddiBoo HB User
Re: UTI symptoms....no infection

Look up urethral Diverticulum.

 
Reply With Quote
Old 07-27-2012, 07:10 PM   #8
Newbie
(female)
 
Join Date: Jul 2012
Location: Canada
Posts: 3
azimut24 HB User
Re: UTI symptoms....no infection

Ddouglas86, I was wondering how you are? I've been experiencing about the same symptoms as yours for a month and a half, except that for me, it's not pain but a constant feeling that I have to go urinate...It's driving me crazy...I've been through 3 rounds of antibiotics (Cipro, Septra, Macrobid) and still, no change. The 3 urine cultures I had came back negative for bacteria (but theres white cells and blood in it)...I'm so desperate. The doctor don't know what I have but he told me that it could be interstitial cystisis...I'm so scared. I will call next week to see a urologist but it's very difficult here in Quebec to see medical specialists (long delay)...I'm just so depressed...

 
Reply With Quote
Old 08-03-2012, 06:44 PM   #9
Newbie
(female)
 
Join Date: Aug 2012
Posts: 1
marie301 HB User
Re: UTI symptoms....no infection

i have had the same thing for 8 months...did you find out what it was? thanks

 
Reply With Quote
Old 08-06-2012, 01:30 PM   #10
Newbie
(female)
 
Join Date: Jul 2012
Location: Canada
Posts: 3
azimut24 HB User
Re: UTI symptoms....no infection

I didn't. I have an appointment with urologist wednesday...I hope I'll get some answers...

 
Reply With Quote
Old 08-10-2012, 07:34 PM   #11
Newbie
(female)
 
Join Date: Jul 2012
Location: Canada
Posts: 3
azimut24 HB User
Re: UTI symptoms....no infection

Well...the uro wants me to do more test (scan, cystoscopy) because he don't know what it is...He didn't really listen to me, he seemed in a hurry...I'm not sure that he really understood all my story and my symptoms...

 
Reply With Quote
Old 06-07-2013, 12:25 PM   #12
Newbie
(female)
 
Join Date: Jun 2013
Location: Sanger
Posts: 3
aharper HB User
Thumbs down Re: UTI symptoms... no infection

What was the outcome??? I'm experiencing the same exact thing!

 
Reply With Quote
Old 06-07-2013, 01:48 PM   #13
Newbie
(female)
 
Join Date: Jun 2013
Posts: 2
cheermomma HB User
Re: UTI symptoms... no infection

Hi, I have all the same things. Urine cultures always come back clear. My symtoms seems to bounce around between a few different things. I mostly feel a pinching or squeezing or pressure feeling in the bladder area that comes on anywhere from a couple of minutes to maybe 20-30 minutes after I urinate. Other times I have more of a burning feeling (again after urinating, not during) in the vaginal area. The odd things is, a lot of times I almost feel better when my bladder is very full, although achy from feeling like I have to pee, but it makes the spams or burning go away. I do know I have kidney stones but I don't think that has anything to do with this. The doctor started me on Elmiron yesterday. I'm always nervous starting new meds. I hope we can all get relief soon...

 
Reply With Quote
Old 01-15-2014, 02:38 AM   #14
Newbie
(female)
 
Join Date: Jan 2014
Location: Ireland
Posts: 1
Jacintha HB User
Re: UTI symptoms... no infection

I have suffered as everyone here since my teens, took antibiotics yet again last summer, symptoms returned, urine to lab again and again, no infection, so have just suffered on with them since last July every single day in depressing discomfort. Some time ago someone suggested to me that applying natural yogurt can work, at the time I thought this a little too bizarre but last night, so worn down from the symptoms, I drove to the shop and bought a pot of natural organic yogurt. I ate two spoonfuls, and applied a good dollop between my legs before I went to bed (smelling and feeling a bit daft with zero expectations) but first thing that struck me this morning, was that I awoke naturally, not, as I have become used to, with 'that pain'. First pain-free pee in six months. Seems too good to be true, but at the moment, I feel 'normal'.

 
Reply With Quote
Old 01-15-2014, 05:55 PM   #15
Newbie
(female)
 
Join Date: Jan 2014
Location: Franklinton, La
Posts: 4
Pastorliz HB User
Re: UTI symptoms... no infection

I have suffered the same thing. Then I got to the point where I could not urinate. The catherized me at the hospital and I got a staph infection, not knowing I already had one or two. I ended up with septic shock and kidney failure. Now, when I urinate it is foaming, smells bad, is dark and I drink water all day long and go 3 times a day. I am in 3rd stage kidney failure on the verge of 4th. I would say that at least I can get dialysis. But I can't, I have lupus and it has ruined the kidneys and I have to be put on the transplant list. Lupus runs with fibro. Have your Dr check you for this. So many disease are connected to Fibro and they are missed. I am 64, so I will not get on the transplant list. Let some young kid have that kidney. When it is my time I will go home. As a Minister I am not afraid of where I am going.

 
Reply With Quote
Reply Reply

Similar Threads
Thread Thread Starter Board Replies Last Post
UTI symptoms without the infection DerbyCityGirl Urology 4 05-27-2010 04:28 PM
urinary tract infection symptoms without the infection Kathy287 Urology 10 12-06-2009 12:42 PM
Problem urine test clean but i have symptoms of uti help skipa dee babe Urology 6 12-06-2007 11:27 AM
Recurrent Symptoms - Annoying and Worrisome cmm001 Urology 2 08-05-2007 02:52 PM
20 yrs. old and having all sorts of symptoms, don't know if related or not.. nawsanenawmean Urology 31 07-08-2007 12:27 PM

Tags
bladder, pain, pressure, uti



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Join Our Newsletter

Stay healthy through tips curated by our health experts.

Whoops,

There was a problem adding your email Try again

Thank You

Your email has been added








TOP THANKED CONTRIBUTORS



bhp02 (12), Millard (8), ladybud (8), Mojo88 (6), albedo1 (6), LENNYI (5), jasno999 (3), Jinny Jean (3), dreamer54 (3), aleet7 (2)

Site Wide Totals

teteri66 (1136), MSJayhawk (941), Apollo123 (855), janewhite1 (823), Titchou (769), Gabriel (743), ladybud (667), sammy64 (666), midwest1 (654), BlueSkies14 (610)



All times are GMT -7. The time now is 12:06 AM.



Site owned and operated by HealthBoards.com™
Copyright and Terms of Use © 1998-2014 HealthBoards.comô All rights reserved.
Do not copy or redistribute in any form!