It appears you have not yet Signed Up with our community. To Sign Up for free, please click here....



Lung & Respiratory Disorders / COPD Message Board

  • SPo2 issues

  • Post New Thread   Closed Thread
    Thread Tools Search this Thread
    Old 12-19-2013, 06:21 AM   #1
    Justin12
    Newbie
    (male)
     
    Justin12's Avatar
     
    Join Date: Dec 2013
    Posts: 1
    Justin12 HB User
    SPo2 issues

    Hi, I'm new to this site. Here's a small bit about my story/issue. A year ago from last July I had major spine revision surgery, I came through that ok, my oxygen levels went back to normal. Then last Dec I got aspiration pnemonia and my spo2 levels dropped to mid 70s. I was hospitalized for a week and my pnemonia cleared but my oxygen levels never came back up so I was put on oxygen 2 lpm and I've been on that for the last year ( never been on oxygen before in my life)

    On oxygen my level is 98
    Off oxygen my levels drop to low 80s very fast. But as soon as I put 02 on you can see my levels climb super fast..

    I'm a 36 yr old male and been to every dr under the sun..

    Any idea's???

     
    Sponsors Lightbulb
       
    Closed Thread




    Thread Tools Search this Thread
    Search this Thread:

    Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is Off
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off




    Sign Up Today!

    Ask our community of thousands of members your health questions, and learn from others experiences. Join the conversation!

    I want my free account

    All times are GMT -7. The time now is 03:55 PM.





    © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved.
    Do not copy or redistribute in any form!